Problem With Directory Opus and TortoiseSVN 1.5.0


I'm using Opus v8.2.1.0 and it was working fine with TortoiseSVN 1.4.8. I updated my version of TortoiseSVN to 1.5.0 build 13316 (32 bit) today and now the context menu is not fully visible. What I mean is the area in the context menu where the TortoiseSVN menu items should be is there, but the text can't be seen (like Commit, Update, etc.). Passing the mouse over the area highlights the menu items so they are definitely there, just too small to see. The tooltip also appears when you keep the mouse over a menu item. It works fine in Windows Explorer.

Has anyone else seen this problem? Does anyone know how to fix this issue? I tried downgrading TortoiseSVN to an older version and the context menu works fine again, unfortunately, I can't do anything with the repository once I do this because it's not compatible with the older version.

Attached a screen shot of the issue.

Try changing/creating this registry value (DWORD):


Possible values are 0, 1 and 2. The meaning of them seems to have changed in TortoiseSVN 1.5 so try all three to see works best. There's no need to restart anything after changing the value; it takes effect immediately.

This post suggests that deleting the value may solve the problem, too.

In the worst case you should be able to get text-only menus with no icons (which 0 seems to do now, although 2 used to do that in previous versions of TortoiseSVN; 2 now shows icons for me).

For what it's worth, TortoiseSVN 1.5 doesn't have any problems on my Opus 9 machine. I don't have Opus 8 installed to test with. It's also improved the way the icons look in Vista's Explorer. Seems like 1.5 has quite a few cosmetic changes which weren't mentioned in the release notes.

leo, thanks a lot for your help! Your tip fixed it for me. I was actually missing that key in my registry. I added it and set its value to 0 and the text menu now appears. I tried setting the value to 1 and 2, but they both result in the text menus disappearing again so I'll stick with value of 0 even though the icons don't show up. Thanks again for helping me fix this :smiley:

I had the same problem after upgrading to TortoiseSVN 1.5.0. Thanks for the fix.

The icons are now missing though.

Here are my results with all four states of that registry entry:

Undefined (the way TSVN 1.5.0 installer left it): Menus are collapsed as in original poster's pics
0: Menus are not collapsed but icons to their left are missing (icons were not missing in pre-1.5.0 version of TSVN)
1: Menus are collapsed (same as if undefined)
2: Menus are collapsed (same as if undefined)

Is there any way to fix this without losing the TSVN icons on the context menu?

P.S. Thanks for helping with this TSVN problem.

Upgrading to Opus 9 is the only way I know of.

Whatever the new TSVN is doing to draw its menus with icons enabled, Opus 8 doesn't like it.

Thank you, leo.

Unfortunately, I am now also experiencing this problem with TSVN and Dopus on XP SP3.

Icons do not show up, but the menu is fine. The value of OwnerdrawnMenus does not matter, and neither does removing the key help.

The odd thing is that the icons show up fine in Explorer.

Any ideas?

Ah I just found [Context menu icons for TortiseSVN)

Seems it's going to be solved.

The problem with TortoiseSVN 1.5 icons, Opus and Windows XP has been solved and a fix will be included in the next Opus update. Edit: The update is out now.

(More detail here. TSVN 1.5 changed the way its icons work from the previous version, and not only that but they do their icons differently on Win2k, XP and Vista for some reason. That's why it took a while for us to spot, since it works fine on Vista.)

Edit: Didn't see your 2nd reply while writing mine. :slight_smile:

I have upgraded DOpus to 9.1.1.x now, and I still do not get any context menu for SVN folders nor icons.

I had the problem with the empty context menus before, but was hoping a simple update to 9.1.1.x would have fixed that. Any settings I have to play around with to make this work? TSVN version is 1.5.3 (I run a VisualSVN server and the VisualSVN client trial as well).

Thanks for ideas how to fix that.

Have you hidden 3rd party context menu items? That would hide the Tortoise ones.

Hold shift and right-click. If you now see the items it's because you've set Opus to hide them.

Nope, shouldn't be. See shots attached. The only thing shift-rmb does is it adds the "Pin " menu. BTW. The one screenshot shows the std windows explorer compared to Dopus (on the right). I am using XP Pro (or whatever we have here) with SP3, AFAIK. I wouldn't know what I'd had changed that the menu doesn't appear any more. I see some TSVN entries in the file type menu, though. (can't attach more then 3, so you need to trust me on the Shift-RMB thing).

Are you trying to use 64-bit Opus with 32-bit Tortoise, or vice versa? Cos that won't work.

(But you can install both versions on the same PC if you need to.)

Is this on in Tortoise?

That was it! Thank you very much! Great help. Appreciate it.

Sorry to bring this old topic back to life.

I just installed Tortoise SVN 1.6.6 and am having this exact same problem using DO U.

I read this post and hit the registry but in 1.6.6 the key: "HKEY_CURRENT_USER\Software\TortoiseSVN\OwnerdrawnMenus" doesn't exist.

Would anyone be able to tell me what I would need to edit to allow the menu to display?


[quote="nero"]Sorry to bring this old topic back to life.

I just installed Tortoise SVN 1.6.6 and am having this exact same problem using DO U.

I read this post and hit the registry but in 1.6.6 the key: "HKEY_CURRENT_USER\Software\TortoiseSVN\OwnerdrawnMenus" doesn't exist.

Would anyone be able to tell me what I would need to edit to allow the menu to display?


Just to update my post. I didn't change anything but now I don't see even the collapsed broken Tortoise menu. In Windows Explorer yes however.

Did you reboot after installing the Tortoise update?

It wasn't an's the 1st time I've installed Tortoise. There have never been prior versions on this machine.

Are you using the 64-bit version of Opus but installed the 32-bit version of Tortoise?