Slow startup when network drive is offline!

Hello again Team!
I have this bug a few versions now but now I found time ti write about it.
Currently I'm using latest beta 12.3.3 x64 Pro.
The problem is that at home PC I have a shared drive that is mapped on my laptop.
At home everything is fine and Opus starts fine. When I go to work where the drive is unavailable Opus window opens but the folder tree stays blank about 1 minute. If I open another window then it opens fast. I removed the network drive and it is always fast. When I re enable the problem comes back.
One easy way to reproduce is to enable flight mode close and reopen Opus!
I tried without any luck!!!

Any ideas???

Thank you in advance!!!

Selecting these two options may help if you're seeing this often:

  • Preferences / Folder Tree / Options / Populate contents for local devices only.
  • Preferences / Folders / Auto-Loading / Network drives: Prevent loading.

Sorry still the same!!!


Is ti because the inaccessible network drive was the last folder open in one of the tabs, and being re-opened when you open a new window?

If so, setting up a window that is only showing local folders and using Settings > Set as Default Lister should avoid most attempts to access the network folder when opening a new window. (It's still possible other things may be pointing at it, e.g. Favorites, icons added to toolbars, and so on.)

My default Lister shows My Computer so the mapped drive is there...

I had no problems even with the first 12 betas. I use it many years like this. What is changed?


I can give you an earlier installer if you want to test that theory.

I'm not aware of any recent changes that should affect this, but that's purely from memory and there may be one I don't know of or which had unexpected side effects. So if you know which version it started happening in, we can look in detail at all the changes in that version to see if one may have an effect.

I think it's most likely to be a configuration change than the code, so I'd look through things like Favorites and similar in case anything is pointing at the drive, but if you've already done that and want to try older versions of Opus 12 just let me know which ones you want and I'll make the installers available.

I think 12.1 was OK. I haven't changed my config the last 2 months. Please send me 12.1 link to test it for start!

Thank you!!!


Here's the installer (zipped).

DOpusInstall - (50.6 MB)

Before going back to the older version, I recommend using Settings > Backup & Restore to create a config backup, in case you lose any settings when you go new->old->new again. It's unlikely to be needed, but only takes a few seconds.

Sorry for the late reply,

Version 12.1 not working too.
I reset preferences all to default no fix.
Any other ideas???


Leo can you please reproduce it???

  1. Map a network drive.
  2. Open This PC.
  3. Read mapped drive
  4. Turn flight mode ON
  5. Close Opus
  6. Reopen Opus (Tree takes a minute to show).



Sorry to return to this again but this is a very annoying bug!
Please try to reproduce is to verify if it is a bug or there is a problem in my setup.

Thank you!


If you need a quick answer, my advice is to unmap the drive, and access it via UNC path instead. (Or map it when it is in use and unmap it afterwards. It might be possible to automate that with the network connection coming up and going down, for example, or based on which network the PC is connected to.)

A mapped drive letter pointing to an inaccessible network server has always caused problems in Windows (without Opus needing to be involved). Any attempt to access the drive (e.g. just to get its icon or label) will potentially block for up to 30 seconds if the OS has not already decided the drive is inaccessible (or if it decides it is time to check it again).

Things are often done on background threads so that the 30 second block doesn't stop other things being done at the same time, but it's not always possible to do that, especially if the blockage cascades from one component to another. (Which can have strange results. Something may freeze that is not even accessing the drive letter, because it's waiting for something else which is.)

First of all I don't want to use UNC paths because it is not handled the same way by all programs.
Also mapping and un-mapping is not convenient.
I work many years like this and I'm sure there was no problem in previous versions.
The worst part is that Windows explorer is working fine on Windows 10. (There is a 30sec delay IF YOU decide to use the mapped drive).
Tomorrow I will put back Opus 11 to verify that there is a change to the new version that is causing this!!!

Thank you as always!!!

One suggestion: could you try disabling your anti-virus and see how it goes?

In my previous Windows / Opus installation I noticed that whenever I'd renamed a large file over network, say 2GB avi, it took up to 60 seconds for Opus to hand me over the control. Opus was grayed out and there was nothing I could do about it. I never did some test, but I always blamed BitDefender for it.

On the other hand, after full-wipe reinstallation of W10 and with fresh Opus12 configuration, now everything works well. For years, I was too lazy to start with fresh so I kept upgrading old DOpus 10 inherited configuration. So, it could be something I-don't-know-what leftover from my old DOpus config or really AV was messing with it. And of course, it could be something else, but one needs to start debugging from somewhere. :slight_smile:

1 Like

Thank you very much for your reply!!!

Although Antivirus is not the problem your clean install idea helped a lot!!!

Actually I removed all the /dopusdata folder to force a dopus clean install. And it worked fine!!!

The problem remains when I restore my config but at least I know where to start!!!

Thank you once again,

I will post my final results...


1 Like

I am very happy it worked for you. :slight_smile:
(BTW, I guess you've got like/thanks button for that) :wink:

OK I got the bug!!!

The problem was not the folder tree!!!

The problem is the Field Type="Drives" that takes so much time to populate.

I use two of them as you can see in

Can you please fix it in the following releases???
Is there any other alternative???


Sorry to bother,

but do you have any news???


Please be patient. If we have new we will update the thread. It may take more than two days.

If you've found the Drives drop-down causes a delay when there's an unreachable network server in the list of drives, then remove the drop-down from the toolbar for now.

If you need an alternative, you can make a similar menu using Go DRIVEBUTTONS=-x which will list all drives except X:\.

I'm not inpatient I just thought you might have missed my post because of the weekend!

I changed the drop-down to a menu-button and now it is working ok

<?xml version="1.0"?>
<button backcol="none" display="icon" label_pos="right" textcol="none" type="menu_button">
  <button backcol="none" display="both" label_pos="right" textcol="none">
    <function type="normal">
      <instruction>Go DRIVEBUTTONS OPENINRIGHT</instruction>

But I like the drop-down version. Also Drives toolbar is working fine with the mapped network drive.