The search box does not work on drives mounted to folders

I mount some hard drives to folders on a partition called 'A:' (A:/Drive 1, Drive 2, etc.).
The Directory Opus search box seems unable to search within these locations.
The results are always blank.

  • I'm using Directory Opus 12.26 on "Windows 10 Pro x64 Version 21H2".

  • I use the built-in "Administrator" account. According to an earlier post on this topic, using this account means there should not be any "UAC" related concerns.

  • The expanded 'Find' tool works on every location.

  • The search box works on the normal partitions & their subfolders (C: & A: etc.). In regards to indexing, the "C:" drive is indexed, whereas the "A:" drive is not. So I don't think indexing is any issue here.

Can anyone help me with this issue?
Most of my work is on these mounted hard drives, and I need the ability to conveniently search them.

The search box uses Windows Search. Opus just displays the results. Do you see the same issue if you do the same search using the search box in File Explorer?

(Tools > Find Files uses Opus's own functionality instead of Windows Search.)

Hi Leo, I just did a side by side test of both Directory Opus and Windows Explorer.

I loaded up the image folder from a mounted hard drive in Windows Explorer:

I searched for 'Bruce' and instantly got results in Windows Explorer:

Then in Directory Opus, I loaded the same folder:

But Directory Opus always throws a blank results screen when searching inside mounted hard drive folders:

Again, I only get this problem when searching within folders that are mounted hard drives.

I can go to any normal folder in that "A:" partition and Directory Opus search box will work perfectly fine.

Hi sorry to bother, but can anyone help with this issue?
Is there some log or something I can send to help narrow down the problem?

Patience, please. We may answer things which are quick over the weekend, but if something takes time to set up and test then it may have to wait until after the weekend. (In my timezone, the first post was 11pm Friday night and the previous post 11pm Sunday night. It's also a holiday here today but I'm working anyway. :slight_smile: )

I've created a test setup with two mounted volumes and the search field seems to work fine with them:

One difference between how File Explorer and Opus use Windows Search is in whether file contents are searched, in some situations, if you don't explicitly specify you only want filenames. So it's possible the search is working but taking a longer time than expected.

Try searching for name:~=Bruce instead of Bruce (which is Windows Search's syntax for finding Bruce anywhere in the filenames but not searching contents) and see if that works to test that theory.

Does your Opus window title (very top left of the window) say "ADMINISTRATOR" anywhere? If it does then there might be an issue, but it should be OK otherwise.

Hi Leo, I understand and will not bump in the future. But thanks for responding.

I tried your search suggestion of "name:~=Bruce" but that also didn't work.
Typically I might notice an animation or indication work is being done to search, but in this situation with the mounted drives (no matter what is entered in the search box) I get an instant blank page as a result:

Also in regard to your suggestion about the built in Administrator window title simply reflects the existing folder name. However, I notice a button on my toolbar that says "Admin":


So this is the bizarre thing...

  • The way the drives are connected is irrelevant. Whether internal or external drives, when mounted to folders the search box will not work.

- But if I mount those same drives to a drive letter - the search box will instantly start working!

It makes no sense.

I'm not really sure what's happening there. When I did my own tests, the drives had no letters assigned and were only mounted in folders, which should be the same thing.

Maybe a Process Monitor log of what happens when the search is done will shed some light on it:

Thanks for the logs sent today!

I think I've reproduced the issue and have done a fix which will be in 12.26.2 beta.

Another strange thing is that today I cannot get Windows Search to work when in the parent of the mount points. It seems to skip mount points entirely now, which was not the case the last time I tried it. (The coming fix doesn't affect this either way.) It's also true in File Explorer, so it seems to be how Windows Search itself behaves, and is probably outside our control.

Searching when below a mount point is now working, where it wasn't for me earlier today. (I'm not sure if that also changed since I last tested in December. I think it worked for me back then. Maybe Windows updates to do with how Windows Search handles mount points were on your machine but not on mine yet, which would explain both differences. Or there's some other factor involved in how it decides to handle them. In any case, it's working the same in Opus and File Explorer for me after the change I've made.)

(Tools > Find Files is unaffected by any of this and will understand mount points already, as it doesn't use Windows Search.)