TortoiseSVN Shell Extension & Icons not working

Hi,

After a recent update of both TortiseSVN and DOPUS, the TortiseSVN shell extensions do not show when I right-click on a directory/file managed by the SVN repository. The menu & icons appear correctly in Explorer but no in Directory Opus.

I've checked settings suggested in various articles about blocked extensions etc. and cannot find anything that seems to be related.

I have reinstalled earlier version of TortiseSVN that I know to have worked previously, but this has not solved the issue. After many restarts I'm at a bit of loss of what to look for next.

Any help of suggestions for further areas of investigation would be appreciated.

DOPUS Ver: 11.5 x86, Build 5298
TortoiseSVN Ver: 1.8.7, Build 25475 - 32 Bit

Paul

Our Tortoise CVS / SVN icon overlays don't show FAQ has all the suggestions we know of.

I am using the same versions of Opus and SVN (except both are 64-bit instead of 32-bit, which shouldn't matter) and the icons are working here.

There is a newer version of TortoiseSVN, but since neither of us are using it the TSVN version is probably not a factor.

Hi Naleo,

I've seen your post on my search; I understand you had the problem a while ago. I'm having exactly the same issue with Tortoise SVN. Its shell works perfectly with its overlay icons in Windows Explorer and not at all in Directory Opus either one shell and icons overlay. The Directory Opus version that I'm using is the 12.17. I believe you must have had a solution to this issue with Directory Opus with the Tortoise Shell.

Thank you
Robert

Have you tried everything in the FAQ I linked?

Using status icons is best as you don't have to worry about the tiny 16 overlay icon limit in Windows then. The FAQ talks about both these things.

Thank you, I will check the FAQ.

Hi Leo,

I've read the about "Tortoise CVS / SVN icon overlays don't show"

on the following link


I've unchecked the Display generic icons the overlay icons is not showing up.

First, I think I need to solve the Tortoise shell in Directory Opus and only then I will see the overlay icon. The problem stills when I press the right button of the mouse Tortoise Shell is not appearing.

The following link to get to the Tortoise-shell issue is not working
https://resource.dopus.com/t/problem-with-directory-opus-and-tortoisesvn-1-5-0/6336.]
I'm receiving the following message.
"Sorry, we couldn't load that topic, possibly due to a connection problem. Please try again. If the problem persists, let us know. Try Again "

Robert

That thread is here, but it's over 10 years old and only really applies to Opus 8.

Hi Jon,

Is there any other thread that is talking about the issue with the current version 12.17 of Directory Opus and TortoiseSVN 1.12.2, Build 28653? This is the only thread that I found that had exactly the same problem regarding the shell and icon overlay. To let you know Tortoise SVN is working perfectly with Window Explorer, I see the shell as well as the icon overlay.

Thank you
Robert

Not that I'm aware of. We use Tortoise ourselves and haven't noticed any issues. The suggestions in the FAQ (including the Status column) are probably your best option.

Since I need first to solve the issue by getting the TortoiseSVN within the shell in Directory Opus. I've uninstalled some programs that are using the contextual menu. If I understand right, I do not think it will cause a change since the limitation of 15 is regarding the icon overlay not the shell. It did not make the TortoiseSVN shell getting back in.

Even after reading on Tortoise SVN FAQ web pages the topics "After installing, there is no TortoiseSVN context menu for files," , https://tortoisesvn.net/faq.html#ovlnotshowing; by giving the permission to the account total control on writing and reading the contextual shell menu do not appear. Even a repair installation did not work out.

The problem is between the TortoiseSNV shell implementation use by Directory Opus since it works with Window Explorer. The funny part I installed other programs that use the contextual menu no problem occurred, search me. Where's the glitch?

Thanks for responding Jon,
Robert

Is TortoiseSVN enabled outside of Explorer? Does it show up in the File Open dialog from Notepad, for example?

Does it appear if you hold shift and right-click? (If so, Preferences / Miscellaneous / Windows Integration / Hide Windows items on file context menus (shift overrides) is probably turned on and hiding the menu by default.)

Check it isn't blocked via Preferences / Miscellaneous / Advanced [Troubleshooting]: ignore_context_menus as well. (That setting is normally blank.)

Make sure Opus isn't running as admin either, as that would probably block TortoiseSVN's components from talking to each other. (Opus will say ADMINISTRATOR in the titlebar if that's the issue. Using UAC and Admin mode within individual windows is fine but elevating the whole process from launch will cause problems.)

Hi Leo,

Great, I've checked Notepad with two other programs that has access to File Open dialog; the behaviors are exactly the same as Directory Opus. Meaning only the Window Explorer is showing up the Tortoise Shell. There must be some place in Window where the Shell is hiding other than where it is handled with Regedit or may be another register key.

For the preference within Directory Opus, I have checked Hide Windows items on file context menus (shift overrides) it is not checked. I have checked it to see the differences. When I do so, I see only the Windows OS shell, and all others are disappeared.

And for the ignore_context_menus troubleshooting as you mentioned it is blanked.

For Directory Opus, I do not see the ADMINISTRATOR in the title bar area.

Thank you Leo for your help, hoping to find where this is happening,
Robert

That puts the issue outside of Opus, at least.

What you're seeing would usually be caused by the option in TortoiseSVN to only affect Explorer:

1 Like

Hi Leo,

I should have really read, when I'm looking on what I see, it is so obvious that I feel ridicule. What I can say, sorry for the inconvenience. Well, the most important part, now, TortoiseSVN shell works very nicely in Direcrory Opus. I can get back to work. I thank you very much Leo for your help. To let you, Directory Opus is a very helpful tool that I use daily.

Thanks again and have a great day,
Robert