Using DO with admin rights

Hi everybody,

I have a problem with using DO while used with another login (for example administrator). 

I'm logged in a normal user, problem is that, while using DO with administrator rights (reduced), when i click a folder (in explorer), DO opens automatically folder. I think there is a problem, because both normal and admin DO preferences are with "do not replace explorer" properties.

So, i would like to know if someone knows how to solve this problem, or, if no solution is found, if it is possible to close COMPLETELY DO after clicking exit button.

Thanks a lot for any help.

Sounds like the "do not replace explorer" setting hasn't taken effect properly as Opus should only handle folder double-clicks when set to replace explorer.

I would log out of both accounts, then log in to one and turn ON explorer replacement, Apply, then turn if off again and apply. Then logout and do the same for the other account.

No, it doesn't work. f it is possible to close COMPLETELY "DO" after clicking exit button?

After you select Exit (e.g. from the File menu or Tray Icon) Opus will exit completely (after a few seconds sometimes, check in Task Manager that dopus.exe is no longer running).

But if the Folder filetype is configured to launch Opus (which is what the Explorer Replacement mode does when turned on) then when you double-click a folder Opus will be launched again. It sounds like that is what's happening.

In fact I close windows as anyone... by clicking on the "close" cross. In fact, the tray icon is getting on my nerves, because I don't want to use this feature, and I'm sure that if i can disable it definetively it would solve my problem.

If you select Exit from the Tray icon then Opus will exit completely, and the tray icon will go.

If the problem still exists (i.e. double-clicking folders still opens them in Opus even when the tray icon and dopus.exe are not running) then the tray icon isn't the cause of the problem.

(Of course, you may dislike the tray icon for other reasons, but let's leave that discussion until after the main problem is solved.)

Assuming the problem does continue when Opus isn't running, open RegEdit and go to


You'll probably see it references Opus. There should also be a key called


which is what I think Opus will try to write over the "open" key when you turn off Explorer Replacement Mode. If that isn't working for some reason I would try doing it by hand in regedit.

If you rename the Folder\shell[b]open[/b] key to something else and then import the .reg file inside the attached zip it will hopefully repair the problem. I haven't tested this, though, and I don't know why Opus is failing to do this restoration for you. (Does the "dopus_backup" key exist?)

If you find you can't double-click folders between renaming the key and importing the .reg file, use Start->Run to open Explorer.exe and use the Folder Tree to change folders.

(Attachment deleted)

This is awfully strange... it doesn't bother me in the slightest since I want to replace explorer all the time buuuut:

I normally have Opus set to replace Explorer for all folders... so I opened Explorer and much to my surprise, double-clicking on a folder in Explorers file display area just opened that folder in Explorer.

I then went to the Start menu and tried clicking on a system folder link (Network Connections) which prompty opened up in an Opus lister as I'd expect... so that was still 'ok'.

I then turned off Explorer Replacement mode in Opus and verified that the folder\shell\open registry command was reset back to run %SystemRoot%\Explorer.exe /idlist,%I,%L. Like Nudel... I understand what happens in this part of the registry when Opus is set to replace explorer and inserts a dde call to dopusrt instead of explorer for the shell\open command...

So imagine my continuing surprise when double-clicking a folder in Explorer NOW opens an Opus lister!!!

I don't know if there is something in any of the dde command linkage that could not be getting updated properly... I'm not sure what to track any of the info in there back to. If nobody has any ideas, I'll go ahead and submit a bug report to GPSoft after trying a clean VM image and installation of Opus minus my normal preferences...

edit note- Leo... the reg export you posted seems to have unicode like block characters between each regular character when I compare it against 'my' exported reg data with Araxis Merge. Looking at it notepad seems 'normal' but regedit cannot import it. Doesn't matter to me as the info was already the same... but I was curious how you exported that key.

I exported it with RegEdit but then edited it in TextPad to correct the paths. Maybe that made it go wrong. Apologies if it doesn't work. :frowning:

/me mumbles about inconsistent (if any) Unicode text file support in Windows programs

It's interesting you've been able to reproduce the problem that mudounet is seeing. I just tried but I can't reproduce it here so there must be a trigger for the problem. If you can think of anything to try or want to compare any settings against my system let me know.

I've tried switching between Replace explorer for all file system folders, Replace explorer for all folders and Don't replace Explorer in various combinations without experiencing the problem. I haven't tried the bottom option, Replace Explorer for all but the following folders, but if that's what you were using before you saw the problem let me know which folders you had excluded and I'll try doing the same on my computer.

Edit: I just noticed that even when Opus replaces Explorer on my system I can double-click folders in Explorer and they open in the same Explorer window, not Opus. This is weird as I have definitely seen that cause Opus windows to open in the past (when Opus is replacing Explorer). I can't think of any settings in Explorer that would be different for me since the last time I saw this.

Edit 2: I killed and restarted Explorer, then turned on Classic View (i.e. no tasks pane on the left of Explorer windows), then turned on Explorer's folder tree, then off again. And toggled Opus's Explorer replacement mode a few more times. After doing that I now have it so that, when Opus is replacing Explorer, if I double-click a folder in Explorer when the folder tree is not displayed it opens an Opus window. If the folder tree is displayed it always opens in the Explorer window. That's the behaviour I've been used to seeing in the past and I don't really know why it wasn't happening for me this morning. Maybe restarting Explorer is an important factor. (End-Task explorer.exe with Task Manager so the desktop and taskbar are gone, then start a new explorer.exe with Task Manager.) I still can't get the problem to occur when Opus is set not to replace Explorer, though.

Hmmm very strange indeed.

In the meantime, while we try to sort things out maybe mudounet can simply enable Explorer Replacement mode - LOL. Maybe that will - ahem NOT replace explorer 'inside' explorer the same as we've seen... but other ways to system folders will still open in Opus (i.e. start menu, systray network icons, etc).

I've attached a fixed .reg file. This is an export of the Folder Open key for Explorer (i.e. Opus set not to replace Explorer). Delete the existing Open key before importing this one:


I just had a thought about what may be causing the problem. Can someone who is experiencing it check the Folder Open key under these two locations:


Perhaps the problem is caused by the way HKEY_CLASSES_ROOT is a merge of those two locations, and only one of them is being updated when you change settings in Opus. In particular, a non-admin account may not be able to change the HKLM value which may lead to confusion and/or different things happening in different accounts (which is even more confusing when the shell and Opus are running under different accounts within the same session). (568 Bytes)

Hmmm... not sure if I caused the problem I was seeing by having changed this 'manually' or not, but I found the problem.

BTW - I did not have any 'folder' key under one of those paths Nudel... HKEY_CURRENT_USER\Software\Classes; the one under HKLM looked the same as HKCR\Folder though, and there did not appear to be an 'out of sync' issue at play (for me anyway). Good guess though, I hadn't thought of that.


The base [b]HKCR\Folder\shell[b] 'default' value was set to openindopus, which of course will always run dopusrt.exe. I manually deleted this default assignment, and now I do not see the same conflicting behaviour. Of course, now doubleclicking folders in 'Explorer' does not open an Opus lister even if Explorer replacement mode is turned on... which I guess is actually normal eh? The important thing is that accessing system folders in other ways (shortcuts, start menu links, etc) opens those items in Opus as you'd expect when 'replace' is turned on...

Do you know if that's something you set using the Open With menu/dialog, or something that happened without your doing anything like that on purpose?

Yeah... the memory is slippin - that's why I was saying I wasn't sure if I might have inadvertently caused this myself by monkeying around in the reg manually (as I often do :slight_smile:). It's the main reason I usually try to test on a ~non-polluted-by-steje-hacking~ image before making bug claims... At any rate, let's see if any of this info sheds light on mudounets' install.

? mudounet ?