GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Dopus 12.19 does not start

Program does not start. Reinstall does not help. No crash dump file. Event log:
Log Name: Application
Source: Application Error
Date: 2/27/2020 11:01:22 AM
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Computer: RW08
Description:
Faulting application name: dopus.exe, version: 12.19.0.0, time stamp: 0x5e12c270
Faulting module name: ntdll.dll, version: 10.0.18362.657, time stamp: 0x64d10ee0
Exception code: 0xc0000374
Fault offset: 0x00000000000f92a9
Faulting process id: 0x4c44
Faulting application start time: 0x01d5ed7c77c535af
Faulting application path: C:\Program Files\GPSoftware\Directory Opus\dopus.exe
Faulting module path: C:\WINDOWS\SYSTEM32\ntdll.dll
Report Id: 504edd89-7885-4b07-b026-e8d5e163ce0d
Faulting package full name:
Faulting package-relative application ID:
Event Xml:



1000
2
100
0x80000000000000

32745
Application
RW08



dopus.exe
12.19.0.0
5e12c270
ntdll.dll
10.0.18362.657
64d10ee0
c0000374
00000000000f92a9
4c44
01d5ed7c77c535af
C:\Program Files\GPSoftware\Directory Opus\dopus.exe
C:\WINDOWS\SYSTEM32\ntdll.dll
504edd89-7885-4b07-b026-e8d5e163ce0d





Exception code: 0xc0000374 means something has corrupted the memory heap within the process. Often due to something freeing memory that has already been freed, or writing garbage into random memory locations.

This could be code in Opus itself, possibly an undiscovered bug triggered by a certain file or files in the folder(s) Opus is opening initially.

It could also be caused by a shell extension something else has installed which is corrupting the heap when Opus queries it (since they run their code within our process as well). That may (or may not) also be triggered by opening a particular file/folder.

I would try creating an empty folder on the desktop and double-clicking that so Opus opens it to see if that works. If so, try looking at the content of the folder that would normally open first and see if any of the files in there is the trigger. (e.g. Copy some of the files over to the empty folder and see if the problem starts happening there.)

Knowing the file or type of file can help work out which component is causing the problem, and we can also test with the same file here to check if it's something Opus itself has a problem with.

Thanks for getting back to me so quickly. I created a new empty folder. Opus would not open when I selected Open In Directory Opus.

Did this start happening when you installed 12.19 (it's a few weeks old now)? Or is there another change on the machine that is more likely to be the trigger? Was anything new installed or updated recently?

12.19 was installed on 8Jan20. Problem started 25Feb20. Upgrades by day: 25 Quicken installed same day as problem, 19 ExpertGPS, 18 Evernote, 14 Multiple Adobe Creative Cloud updates, 05 iCloud & iTunes. January: 31 Microsoft Office updates, 21 RoboForm & Snagit, 20 FreeFileSync, 14 Quicken. Windows: Security Update for Windows 10 Version 1903 for x64-based Systems (KB4524244)
Successfully installed on 2/14/2020
2020-02 Security Update for Adobe Flash Player for Windows 10 Version 1903 for x64-based Systems (KB4537759)
Successfully installed on 2/12/2020
2020-02 Cumulative Update for .NET Framework 3.5 and 4.8 for Windows 10 Version 1903 for x64 (KB4534132)
Successfully installed on 2/12/2020
2020-02 Cumulative Update for Windows 10 Version 1903 for x64-based Systems (KB4532693)
Successfully installed on 2/12/2020
2020-01 Cumulative Update for .NET Framework 3.5 and 4.8 for Windows 10 Version 1903 for x64 (KB4532938)
Successfully installed on 1/15/2020
2020-01 Cumulative Update for Windows 10 Version 1903 for x64-based Systems (KB4528760)
Successfully installed on 1/15/2020

Since it started happening several days after the Opus update was installed, it makes sense to check if any of the other software updates might be involved.

If you download ShellExView (grab the 64-bit version) and run it, it will show a list of all shell extensions installed by software on your system. I recommend looking through that list for anything related to any of the updated software you mention, and disabling it.

(To disable things in ShellExView, right-click and choose the Disable option. Reboot after you're finished, to ensure they aren't already loaded into anything. You can re-enable them in the same way when you're done.)

If you still see the problem even with everything disabled, please let us know and we can suggest other diagnostics. But if you find a particular component is causing the problem, updating it or leaving it disabled should solve the problem. Let us know what you find as we can see if the same thing happens for us and block problem components if needed.

The only thing that looked suspicious was some OneDrive extensions. I disabled them and rebooted. Problem still occurred. I have attached 2 files with the disabled extensions and all extensions.
Desktop.7z (18.1 KB)

I tried something that worked, but I cannot explain why. I tried dopus.exe in Windows 7 & Windows 8 compatibility mode. It still did not work. I then rebooted the computer after resetting compatibility mode and Opus started working. Did a power down and start and Opus came up. Any thoughts on why this started working after using Compatibility mode?

I don't know why that would fix things. The reboot may have been the real fix.

Just today I rebooted at least 7 times without fixing the problem. Since the problem started I have at a minimum did 2 Shut Downs and power ups a day without fixing the problem. That along with multiple Reboots to no effect. I am assuming that Compatibility mode works heavily with the Windows registry. Will get back to you if problem comes back.

Maybe something was wrong in the registry which toggling compatibility on and off reset.

Or maybe something else got updated on that reboot. That would be my guess, but we can't know for sure.

Thanks for your help.

Opus ran well for 2 days. Today I had a digital recorder plugged in as a USB drive and was using your Visual Pane to listen to the files. When I went to delete a file on that device in Opus, the program crashed. After the crash the program would not start over 2 separate restarts. I then ran the "Run compatibility troubleshooter" from properties. The attached file shows the results of the run. It switched the program to Windows 8 compatibility. I was able to start the program then and also from several restart cycles.
Opus Compatibility

You don't want any compatibility settings to be turned on for the Opus executable. We recommend turning off any that Windows decided to turn on.

What kind of file was it? My guess is a component involved in viewing, thumbnailing or extracting metadata/columns from that type of file is probably involved in the crash.

Were any crash logs created that time?

Do you still have all the shell extensions that were disabled before disabled now? If they were re-enabled after things started to work again, one of them is probably the cause.

The file that I tried to delete that crashed Opus was a MP3 file. I just played the file in Opus "Viewer Pane" successfully. No crash logs were in "C:\Users\Ray\AppData\Local\Temp". None of the shell extensions that I disabled allowed the program to start again. I included a zip file on Feb 28 that contained the shell extensions that I disabled and the complete list of shell extensions.

Opus just crashed again. I was creating a directory in Program Files to hold the Shell Extension Viewer. Opus could not be opened after that until I ran "Run compatibility troubleshooter". I did not change the compatibility to Windows 8 and noticed that it runs Windows 10 compatibility until next crash. Looked through shell extensions for an extension for shift delete and directory create but could not find them. There was no Opus crash dump.

The problem you're having is something is corrupting memory within the process (at least based on the info so far), which often means that something which happens later ends up crashing but isn't really involved in the problem. It's like one component leaves a banana peel on the floor and then exits the scene, and then something else trips over it, but wasn't at fault.

Memory corruption may also explain why the crash dumps aren't saving, since if the process's memory is corrupt then the crash handler may not be able to run itself.

Unfortunately, tracking down the cause of such a thing can take a lot of trial and error. I would disable all shell extensions and reboot to see if that might help (if it does, start enabling a few at a time until the problem comes back, to identify which one is at fault).

If you have any video files in folders you visit before the problem happens, they could be a trigger (often in conjunction with a buggy video codec or splitter that something has installed).

Making a note of which folders, and the files and types of files inside them, Opus displays before the crash can help point in the direction to look in.

The start problem has become more predictable. The program cannot be started after a restart. No crash log. Disabled all non-Microsoft shell extensions. Program still does not start. The only way to start the program is using the Compatibility troubleshooter. Is it time to try another version of the program or use a beta?

In the process of looking for clues I noticed Other | underThisPC that was not there before. Notice the duplication of Documents and others. Opus is still not opening after a restart. Compatibility always allows me to open it. Occasionally after a restart I open my new empty folder and it opens Opus for a few seconds and disappears.
Opus New

Could you make a Process Monitor log of what happens when you launch Opus for the first time?

That may reveal something unusual, either a folder that is being accessed or components being loaded into the process which might be causing the problem.

Do you see the same duplicate folders in File Explorer?

It may also be a result of the compatibility settings you've applied, since Opus filters that list differently for different versions of Windows.

Do you know which settings it has changed? It could be complicating things more than helping, since it's difficult to know what it has changed and whether those settings are still in effect, or how to clear them if they are.

Normally, any change you apply using it would still be in place after a reboot, so I'm not sure it's really fixing the problem if the problem comes back each day.

Some of the Microsoft extensions have had bugs in recent years as well. It might be worth disabling them as well, in case they're involved. Be sure to reboot afterwards, and re-enable things later if it didn't make a difference.