GP SoftwareTwitter
Opus FAQsManualCommandsObjects

License Manager Error. DOpus won't load

Hi,

I had some disk drive problems a few days ago and had to move my C: Drive(which did not have any problems) to another drive. The other drive is now my Windows drive and it boots and everything else runs fine. But DOpus 11.19 crashes on loading now and gives the License Manager error(see pic below). I tried re-installing 11.19 and that did not help.

Any help is appriciated!!
Thanks!

DO11.19 License Mgr Error

What type of error happened with the old drive? Hardware failure, or something else?

How did you move the C drive to the new drive?

Is it possible files on it which were part of Windows have been corrupted?

Is the new drive also called C or has the letter changed?

No, there was no Hardware failure.. I had 2 SSDs in RAID 0 for a long time, and recently was told that it makes them slower. I noticed that they were not running up to spec. And it was my C: Windows Drive. So I used Acronis True Image 2016 to make a backup image of my D: drive, and then used the 'Clone Disk' utility to move C: Windows to my D: M.2 Drive. That booted up fine. I didn't test DOpus at that time. I just made sure it booted ok and ran ok, so I rebooted a few times. At boot the system had changed my D: M.2 Windows drive to letter C. And all was good. So, I removed my 2 SSDs from the RAID 0 and made them separate drives. Then I Cloned Windows from that C: (D:) drive back to one of the SSDs because that's where I wanted Windows. Now that drive was C: and it boots up fine. But then I went to use DOpus and got an Error that my license was invalid or something. I got that error maybe 2-3 times. I think I rebooted a few times and tried it again and now it says this error that I first posted about..

Windows or the BIOs has always changed the Windows Drive to C: every time. Which I like..

I ran the Error Check tool in the C: Properties page and it found no errors. And I Defragged it but it didn't need it. It ran in about 4 seconds.

You would need to reinstall the licence after changing drives, so the first part of that is normal.

But I don't know why it would start crashing like it is in your screenshot.

  • Was anything else done between the time it was asking for a licence and when it started crashing?

  • Try deleting the C:\ProgramData\GPSoftware folder, then run the Opus installer again. Does that fix things?

It should ask for the licence, but not crash. You can get the licence from https://www.gpsoft.com.au/DScripts/lostcode.asp if you don't still have it in your email.

Hmm... I Uninstalled DOpus and deleted it's folder and rebooted. I installed 11.19 again and when I run it the same thing happens. Are there other files or registry items I should look into?

Also, I was thinking....

I have an F: drive that became unreadable and I lost all of the data on it. I wonder if DOpus License Manager looks at your hardware config to ensure it is installed on a licensed system, and that it gets an error when trying to read that failed partition?

Did you delete the folder I mentioned under ProgramData, or the one under Program Files?

I deleted the one under Program Files.
I don't see any GPSoftware folder in C:\ProgramData...

Thanks for checking. It may already have been deleted when you uninstalled, although it would usually have been recreated again.

Do any crash logs exist?

Yes, and I just emailed them to your crashdumps email.

Thanks.

Based on the dumps, it looks like something is closing the Licence Manager window as it opens. Has anything been installed which might do that, e.g. to stop the licence manager appearing?

You may be able to work around the problem by installing your licence via the command line:

"C:\Program Files\GPSoftware\Directory Opus\dopus.exe" /cert "<cert filepath>" /regcode <registration code> /norun

Thanks!!! That command line worked.

I had backed up my DOpus folder. Can you tell me which folders/files to copy over to restore my settings? I had recently changed several things and had not made a Preferences backup.

Config folders are listed here: How to backup or locate your Opus configuration (Simple)