GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Postscript-Viewer (ps, eps) (32-bit only)

32-bit-only
no-unicode-support

#1

View Postscript- (.ps) and EncapsulatedPostscript-Files (.eps) in DOpus-Viewer pane with this simple Viewer-Plugin.

Ghostscript has to be installed (you'll need the Ghostscript-Dll at least)

It should work under 32bit XP and Vista.

Feedback is welcome :slight_smile:

Current Version: 1.1.1 (11.02.09)

Please take a look at these files:
readme.txt => further information and usage
history.txt => changelist

ATTENTION:
Referring to this post, please use my PlugIns only with DOpus 9.1.1.8 or higher! I'll limit the usage to this version in a further release. Thanks.

PSViewer.zip (272 KB)


EPS viewer plugin?
Heads-up: dopus_fileinfo crashes and solution
#2

hey i am running 64 bit vista and 64 bit dopus - the plugin is not showing up - i have ghostscript installed also i copied the .dll to the viewers direcory .....

so far nothing :frowning:


#3

Sorry, but I am not able to test the Plugin under 64bit Windows :frowning:
Did you copy the GS-Dll into DOpus' Root Directory?

Anyone else with 64bit Windows here, who have tested the Plugin?


#4

Since the plugin is a 32-bit DLL it won't load at all in the 64-bit versions of Opus. A 64-bit DLL would need to be compiled (or some kind of 64-bit -> 32-bit proxy plugin made).

(The ActiveX plugin can do this, but uses a 64-bit to 32-bit proxy where necessary to load 32-bit components in 64-bit versions.)

64-bit users who want to display Postscript files should be able to do so by installing Ghostscript, from what I have read. The Ghostscript installer installs a viewer for Internet Explorer and the ActiveX + Preview + Office + Web plugin for Opus can be configured to take advantage of that: Go to Preferences - Plugins - Viewer Plugins, select the ActiveX plugin and click Configure, then add the .ps and .eps extensions under the Internet Explorer (32-bit) section. Those file extensions will then be displayed in the Opus viewer pane via IE.

Update: Turns out this is incorrect. Ghostview does not provide a viewer that works in Internet Explorer, despite its webpage suggesting it does.


#5

Since the plugin is a 32-bit DLL it won't load at all in the 64-bit versions of Opus. A 64-bit DLL would need to be compiled (or some kind of 64-bit -> 32-bit proxy plugin made).[/quote]
Thanks for this useful information. I never worry about 64bit architecture specifics until now :confused:


#6

With C++ and Visual Studio, making 64-bit builds is generally very easy. You usually don't have to do much more than recompile with different settings and maybe fix some bugs where pointers are cast to 32-bit numbers and truncated, usually due to Win32 GUI stuff.

That is if there are 64-bit versions, or source code, for all of your (in-process) dependencies. If you can't make 64-bit versions of the dependencies then things become more complex since 64-bit code cannot load/include 32-bit code in the same process.

I don't know much about Delphi and 64-bit, though. I've read that Borland aren't going to release an x64 Delphi compiler and apparently want people to switch to Delphi.Net, but that could be old information.

Update: 64-bit support is on the Delphi roadmap for mid 2009, apparently.

For testing, if you don't have a spare machine to install x64 Windows, you can use VMWare since it lets you run a 64-bit guest OS on a 32-bit host.


#7

I hope they won't :open_mouth:
If they do against my expectations I'll change to Visual C#

I have a machine, but not an OS :wink:


#8

Thanks, works fine.

But opening vasarely.ps from GS examples using gs32.dll from GS 8.63 shows the file correctly but closing the viewer closes DOpus (not only current lister), no warning, no error.

(Vista, DOpus portable 9.1.1.3.3190.x86)

Addendum 20090206:
PROBLEM VANISHES WITH DOpus 9.1.1.7.3307


#9

Hmm, I can't reproduce this.
Anyone else who can?

Is it only the mentioned file?


#10

From the GS examples also tiger.ps and snowflake.ps show this behavior, the rest is OK.

Interestingly (if I open viewer pane in the lister) I can change files and the view updates, but

  • closing the pane (if I had viewed one of this files) closes DOpus
  • changing to often (also only if i had viewed one of this files) closes DOpus also

Seems to be something with the PS.

Not severe, I can live with it, my "normal" ps files work like a charm

Addendum 20090206:
PROBLEM VANISHES WITH DOpus 9.1.1.7.3307


#11

I am awfully sorry but I can't still reproduce this behavior yet with DOpus 9.1.1.6.3274 and Ghostscript 8.14 :confused:


#12

Thanks, I will update DOpus and come back with results. Thank you very much.

Addendum 20090206:
PROBLEM VANISHES WITH DOpus 9.1.1.7.3307
THANK YOU


#13

hello, i tried your suggestion about activex but now this happens when i click on an .eps file ...

i have ghostscript installed as well as gsview both latest versions

(see image)


#14

Bootman, you're right. GhostView's web page makes it sound like it allows you to view Postcript files in Internet Explorer but that seems not to be the case.


#15

Bugfixrelease (Post #1)


#16

PSViewer doesn't show in the plugin manager, all other plugins from Dinkelhopper do. OS is Vista32 and the gsdll32.dll v8.64 is in the same directory as the plugin.

Regards, Norbert


#17

You have to copy the Ghostscript-Dll to the DOpus-Root-Directory; not the Viewer-Subdirectory :wink:


#18

Thanks!

Note to myself: read the readme completely and thoroughly.


#19

New Release post #1
(Bugfix)


#20

Update: A workaround for this problem is included in Directory Opus 9.1.1.8 which just came out.

Please see Heads-up: dopus_fileinfo crashes and solution if you're using this plugin and have found Opus crashes sometimes.

Hopefully it'll be easy to fix but I figure the mysterious crash may be causing problems for some people so it's worth giving everyone a heads-up on how to avoid it for now.