Ridiculous delay on right click

There is up to a c.30 second (timed) delay before the right-click context menu appears

I have a problem with Directory Opus Pro on my new Dell Desktop. When I right click on a folder in the folder tree (left panel) or on a file or folder in the file view panel(s) there is up to a c.30 second (timed) delay before the right-click context menu appears. If I then do a Cut/Copy to move some items, the subsequent right-click to paste the files/folders may or may not have the same delay. I have not found a pattern to when there is NOT a delay. The delay is much longer on a right-click but is sometimes shorter but never as short as when I select a menu item. Key stroke commands work without delay.
The delay happens whenever I run Directory Opus and it does not seem to matter what other applications are running. I have a very powerful PC with Xeon CPOUs and excess memory. Running version 12.30 x64 build 8360. Windows 11.

Delays when right-clicking are almost always caused by shell extensions something else has installed.

See here for how to track down the cause:

Do you have Apple iCloud installed?

Yes. I do have iCloud installed but then I also did on my old PC without this issue.

Thanks

Another user recently found delays when right-clicking which went away after blocking the iCloud extension:

A Process Monitor log of what happens when right-clicking (when the problem happens) could be useful to use in working out what's going on and if we can change something on our side to fix it.

Adding {85527100-19D0-45AF-9F09-DAB4E711C35E} to Preferences / Miscellaneous / Advanced, ignore_context_menus should prevent the problem, if it's the same as the other user saw.

1 Like

The blocking of Apple iCloud did not work so I followed your advice to run the MS Process Monitor. The log file was huge so I have put in a DropBox folder and have given access to your CrashDump email. I have sent link to the email address as well.

The actions I took some seconds before saving the log were to right-click on a file in a Directory Opus Pro Window pane.

BTW File Explorer works fine

1 Like

Can't download the file via DropBox as it's over 2GB and shared in a way that requires it be added to DropBox.

Assuming it is uncompressed (based on the file size), It should compress to a much smaller size if you zip it. I think sharing the file itself, rather than the folder it is in, should also let us download it directly.

A DebugView log as per the Crash, exit or high CPU when right-clicking certain files "Finding the Culprit" steps may also identify which shell extensions is causing the delay. (The ProcMon log will still be useful in working out why the delay is happening, while the DebugView log is the quickest way to work out which extension is triggering the problem.)

I had this problem too, and it was related to iCloud -- but only occurred when invoking a context menu on a OneDrive file. If I uninstalled iCloud, the problem went away.

For me, there was a delay of 30 seconds and then I'd see the following Windows notification pop up:

Directory Opus - iCloud notification after context menu delay on OneDrive

Then there would be another 30 second delay and the context menu would appear.

As suggested in the topic referenced by Leo, I used DebugView to capture a log with context_menu_debug enabled. After some trial and error I found two CLSID's that needed to be ignored.

The first CLSID appeared at line 89, just before a line containing "iCloudDrive + AOSKit".

[18332] [1972] dopus: CLSID: {85527100-19D0-45AF-9F09-DAB4E711C35E}
[16408] [16408 @ Sun Dec 18 2022 15:53:38.269] 2204 WARN DllMain iCloudDrive + AOSKit version 14.1.0.108 

The second appeared at line 170, just before a line containing "iCloudPhotos + AOSKit".

[18332] [1972] dopus: CLSID: {1454BEE1-EC6D-4D38-BCFD-1DA1F91BA46E}
[18448] [18448 @ Sun Dec 18 2022 15:54:08.370] 4416 WARN DllMain iCloudPhotos + AOSKit version 14.1.0.108 

Putting both these entries in ignore_context_menus fixed the problem:

{1454BEE1-EC6D-4D38-BCFD-1DA1F91BA46E}
{85527100-19D0-45AF-9F09-DAB4E711C35E}

Oddly, in my iCloud Settings I have Photos and Drive both disabled. In fact, everything is disabled except Calendars and Contacts. Yet it was CLSID's related to iCloudDrive and iCloudPhotos that had to be disabled in Directory Opus.

If the CLSID's listed above doesn't work for you, generate a log and look for CLSID's just before iCloud + AOSKit.

2 Likes