D8viewer - Sort by date crated instead of naming

Hi. I love the viewer, but one thing that is annoying is the file sorting.
How can I change the "Filename" order to date "Created"? I've searched for it in preferences, but I did not find it.
The best case scenario is to sync the explorer sort with the viewer. I don't know if that is even possible, but would be great!

The quickest solution is to sort and select the files before the viewer gets launched.

not exactly what you asked for but this might help

Thanks for your help.
I've tried this:
Sort images by created > select de images > launch the viewer (pressing Enter) > than all the images open in different instances of the viewer.
That is not really useful because than I have many of instances of the viewer than things will go messy very quickly.

That's cool, but no quite there.
If it work all in the viewer would be perfect.
I don't know why this simple thing is not in the Preferences menu.
Anyway I'll try to use this script for other things👍.

It sounds like Preferences / File Operations / Double-click on Files / Use internal picture viewer for is turned off, and the viewer is being launched like an external program.

Turn that on and the file list will be sent to the viewer from the lister, and kept in the same order.

You only have to double-click (or push Enter on) the first file, too, unless you only want to view a subset of the files in the current folder.

You can also use the Show Pictures command inside the menu of the Slideshow button on the default toolbars, with one or more files selected.

Thank you, Leo. That option was actually turned Off, but now there is an error that says:
DO - Can not launch viewer
"Windows could not find "C:\Program Files\ACDSee\ACDSee32.exe". Be sure that he name was typed correctly and try again."

I've installed this program before, but I uninstalled it because DO and is way better. So I don't know why exactly DO is searching for that path.
I have tried to cheat creating a copy of the "d8viewer.exe", rename and paste in the same folder, but no luck.

Is that a problem in the registry?

I really appreciate your support.

That's a problem which seems to come from importing someone else's config which was set to explicitly launch ACDSee32.exe, but any time I try to ask where the config came, to get a look at it or try to get whoever it is that is sharing/suggesting it to fix it and stop breaking things and causing support problems for us, people stop replying for some reason.

Did you import someone else's config? Can you tell us where it came from?

That's weird because I never imported any config to customize the ACDSee. I did not used more than 2 days. I tried this program just to see what it was capable of doing.
I'm guessing the uninstaller did not removed all the things it supposed to.
Tomorrow I'll try to find any trace left on windows, APP data, or anything else. If I find something or not I'll reply.

I found the solution!
I've searched anything related to ACDSee on the forum and someone gave the answer:

For some reason there was a behavior on double clicking in File types

I didn't even know that this 'Recognized_images' section existed before, but that was the problem.

I have one more question. I don't know if I need to create another thread just for this simple question.
Why the icon of the viewer is the same as the DO (Yellow sphere)? Shouldn't it the blue square like in the top left in the title bar?

This always confuses me when I try to got to the viewer and click the wrong one.

Leo didn't mean that you'd imported an ACDSee config, he was asking if you'd imported someone else's Opus config.

The File types setting you found must have come from somewhere; we'd like to try to track down why people keep turning up with this setting causing problems.

Ow sorry for the misunderstanding.
The only things I imported were some themes from these topics:

A .dlt theme file wouldn't be able to change filetype settings. A .ocb config backup could, and some of the theme threads have those in, but not those ones as far as I can tell.

(I've looked through all the .ocb files on the forum which I could find and couldn't see any with references to ACDSee32.exe in them, unless I missed one somewhere.)

It's quite strange.

We're going to make a code change to ignore the config file in this situation, since we can't find the source of what's doing it. Something external to Opus must be modifying the config file for some reason, or it's being imported from somewhere. Until now there was no mention of ACDSee32.exe in our code, so it can't be coming from Opus itself.

1 Like